The Windows AMI's are outdated, similar to: #304. When trying to start a new instance, it fails with:
[...]
│ Error: creating EC2 Instance: AuthFailure: Not authorized for images: [ami-03440f0d88fea1060]
│ status code: 400, request id: a2a[...]e0af
│
│ with aws_instance.goad-vm["dc01"],
│ on windows.tf line 41, in resource "aws_instance" "goad-vm":
│ 41: resource "aws_instance" "goad-vm" {
│
╵
[-] Providing error stop
[...]
Checking the available AMI's yields:
> aws ec2 describe-images \
--region eu-west-3 \
--owners "amazon" \
--filters "Name=name,Values=Windows_Server-2019-English-Full-Base*" \
--query 'Images[*].[ImageId,Name,CreationDate]' \
--output table
-----------------------------------------------------------------------------------------------------------
| DescribeImages |
+-----------------------+----------------------------------------------------+----------------------------+
| ami-02a45af02cb289e37| Windows_Server-2019-English-Full-Base-2025.10.15 | 2025-10-17T06:33:35.000Z |
| ami-0a4c1700182f3bc09| Windows_Server-2019-English-Full-Base-2025.11.12 | 2025-11-12T23:01:57.000Z |
| ami-0a92dbc1c111021cd| Windows_Server-2019-English-Full-Base-2025.09.10 | 2025-09-12T04:00:23.000Z |
+-----------------------+----------------------------------------------------+----------------------------+
which confirms it. Once ami-03440f0d88fea1060 is replaced with ami-0a4c1700182f3bc09 inside the ad/<LAB>/providers/aws/windows.tf, the new instance starts without a problem
The Windows AMI's are outdated, similar to: #304. When trying to start a new instance, it fails with:
Checking the available AMI's yields:
which confirms it. Once
ami-03440f0d88fea1060is replaced withami-0a4c1700182f3bc09inside thead/<LAB>/providers/aws/windows.tf, the new instance starts without a problem